DH-106s Bastelecke

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Gearbest Tablet-PC Promotion promotion
    • DH-106s Bastelecke

      Der Thread ist ja schon etwas länger gediehen, deswegen kommt hier im ersten Beitrag eine Zusammenfassung der schon fertigen und noch offenen Projekte. Diejenigen, die schon fertig sind, sind anzuklicken und verlinken auf die Downloadseite; die anderen werden noch kommen. Die Reihenfolge ist noch offen.


      Neue Projekte werden hinzugefügt, sobald sie mir einfallen und im Spiel sinnvoll nutzbar scheinen :)

      Airbus: 220, 330, 340

      Antonow: 10, 12,22, 24, 26

      Boeing: 314, 377 Stratocruiser, 707

      Bristol: Britannia

      deHavilland: Comet I, Comet 4/4B/4C, Skate

      deHavilland Canada: Dash 8-300, Dash 8-400, Twin Otter

      Dornier: Wal, Do-X

      Fokker: 70

      FWD: 152

      Handley Page: H. P. 42

      Hawker Siddeley: H. S. 121 Trident

      Iljuschin: 14, 18, 62

      Lockheed: F104 Starfighter, C-130K Hercules

      Sud Aviation: SE210 Caravelle

      Tupolew: 104, 114, 124, 134, 144

      Vickers: VC-10

      Passagierdampfer: MS Mönkeberg





      Guten Tag in die Runde,

      ich versuche gerade zu lernen, wie man für Transport Fever neue Fahrzeuge baut. Eine Tupolew 104 ist gerade in Arbeit und in Blender auch schon relativ weit gediehen (sie ist nicht perfekt, aber es ist einmal ein Anfang). Es wäre also an der Zeit, das Ergebnis einmal im Spiel zu testen und die Skalierung anzugehen. Aber beim Export zum Spiel bin ich bisher immer gescheitert. Der Export mit Merks Addon funktioniert, die Dateien und der Verzeichnisbaum sehen soweit gut aus. Aber wenn ich dann das Spiel starte und den Mod einmal testen möchte, dann kommt die Meldung, daß der Mod "veraltet sei" und ich bitte den Autor für eine aktuelle Version kontaktieren soll.

      Zwei Fragen:

      1. Wo liegt dieser Fehler? Habe ich beim Export eine Einstellung übersehen und exportiere versehentlich in einem Format für Train Fever?
      2. Gibt es bei dem Export-Addon eine Option, die .mdl-Datei automatisch erstellen zu lassen, oder ist die "freihändig" zu bauen?

      Ich danke im Voraus für die Erklärungen...
      Bilder
      • Screenshot.jpg

        282,99 kB, 1.920×1.080, 421 mal angesehen

      Dieser Beitrag wurde bereits 39 mal editiert, zuletzt von DH-106 ()

    • Vielen Dank an alle für die Antworten und die Lösungswege.

      Das Spiel findet jetzt das Flugzeug und bietet es auch zum Kauf an. Die xyz-Achsen werde ich wohl noch ein wenig ausrichten müssen, dann gehts an die Texturen...

      Wenn man das Flugzeug dann jedoch kaufen möchte, dann stürzt TPF noch ab und beschwert sich, daß in der .mdl die Achsen nicht definiert seien. Unter "Train Fever Mesh" habe ich die nicht lenkbaren Räder als "Achse" und das steuerbare Bugrad sowohl als Achse als auch als Rad definiert. Aber in der .mdl kommt davon nichts an. Hat hier vielleicht auch noch jemand einen Ansatz, wie man das löst?
    • Das Bugrad ist nur ein wheel. Sicher das keine axles Einträge in der mdl stehen? Irgendwo ziemlich weit unten. Genaue Fehlermeldung wäre da interessant oder du hängst mal die mdl als code an. Nicht vergessen bei Flugzeugen gibt es noch rudder, elevator usw das kann man im blender alles schon definieren.

      Gute Arbeit soweit btw. :thumbup:
      MfG Maik

      Meine Modelle auf Sketchfab:
      sketchfab.com/maikchaos/models

    • Je mehr ich versuche, das Ding in TPF sichtbar zu machen, desto mehr Respekt habe ich vor denen, die das schon geschafft haben... Aber aufgegeben wird nicht.

      Die Objektstruktur in Blender habe ich jetzt komplett überarbeitet und den Empfehlungen, die ich finden konnte, angepaßt. Der Export funktioniert ohne Fehlermeldung, aber in der .mdl gibt es noch mindestens 2 Probleme:
      1. Die "Wheels" und "Axles" sind zwar im Blender markiert (s. Screenshot.png), aber sie kommen nicht in die .mdl.

      2. Wenn ich das Spiel starte und versuche, die Tupolew zu kaufen, ist die Seitenansicht nicht zu sehen, und wenn ich auf "Kaufen" klicke, kommt eine Fehlermeldung: File: vehicle/plane/Tu.mdl (die Datei ist angehängt) ...models/group/vehicle/plane/Tu-104A_lod_0_Bugfahrwerk.grp:4:Malformed number near '104A'. This error is usually caused by modding etc.

      Ich habe Google bemüht, aber nicht mal diese Fehlermeldung irgendwo wiedergefunden. Kennt vielleicht hier jemand das Problem und weiß, wie man es angeht?

      Nochmal vielen Dank für die zahlreichen hilfreichen Antworten.
      Bilder
      • Screenshot.png

        309,52 kB, 1.920×1.080, 156 mal angesehen
      Dateien
      • Tu.mdl.txt

        (3,36 kB, 54 mal heruntergeladen, zuletzt: )
    • Soweit so gut, orderntlich benannt ist es schonmal nur noch einige kleine Korrekturen

      1. Da wo bei dir noch cylinder etc. steht muss immer jeweils der Name rein der direkt drüber steht, cylinder.018 würde dann also TU-104A_lod_hauprad_rh heissen.
      2. Verwende keine umlaute, dein Mod dürfte ja auch für die russische com interessant sein und grade die haben in den wenigsten fällen den deutschen Zeichensatz installiert, die bekommen aber mit den ganzen ä,ü,ö Probleme
      3. Linux und Max sind casesensitive, das heisst wenn du dich mal vertippst und irgendwo was groß schreibst, was woanders dann klein ist, gibt das auch nen Absturz. Unter Windows wird dir der Fehler halt nie auffallen. Einfache Lösung alles klein schreiben.

      Zum Bugfahrweg, poste bitte mal noch den Inhalt der bugfahrwerk group oder schau selber in Zeile 4 nach, da ist ein Fehler drinne.
      Warum die axle nicht eingetragen wird ist mir allerdings ein Rätsel, wenn du willst send mir ne PM mit dem blendfile dann kann ich mal reinschauen.
      MfG Maik

      Meine Modelle auf Sketchfab:
      sketchfab.com/maikchaos/models

    • Vielen Dank euch allen für die Hilfe. Im Spiel sehe ich das Gerät zwar immer noch nicht, aber lange kann es nicht mehr dauern.

      Der Fehler "Malformed number near '104A'." und auch einige Fehler, bei denen das Spiel nach ] oder } verlangt, liegen offensichtlich daran, daß das Spiel mit Bindestrichen in Meshnamen nicht zurechtkommt: wenn ein Mesh z. B. Tu-104A_ etc. heißt, dann kommt der Fehler; tauft man alle Teile in Tu104A_ etc. um, dann funktioniert es.

      Wie man die invalide Fahrwerkskonfiguration bekämpft und dazu die "Initial Pitch on Ground" unter die offensichtlich kritischen 0,349066° bekommt, muß ich noch herausfinden. Aber da das Fahrwerk ziemlich weit unten in der .mdl definiert ist, muß das einer der letzten Fehler in den Dateien sein. Ich nehme an, daß der Schwerpunkt des Geräts am Ursprung des Objekts liegt, und daß daher die Haupträder hinter diesem Punkt sein müssen, damit das Gerät nicht auf den Schwanz kippt?

      Das ist ein Projekt für morgen...

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DH-106 ()

    • Ich denke mal es wäre dir recht wenn einer der Mod's/Admins das Thema unter Mod verschiebt und den titel auf Tupolev TU-104 [WIP] anpasst, oder? Da passt es jedenfalls gut hin.

      Das Bindestriche nicht gehen wusste ich noch gar nicht (nie probiert). Aber das die nicht gehen klingt logisch, TPF scheint danach immer eine Zahl zu erwarten. Wieder was gelernt.
      MfG Maik

      Meine Modelle auf Sketchfab:
      sketchfab.com/maikchaos/models

    • Ja, es wäre wohl eine gute Idee, wenn dieser Thread an einen angemessenen Ort verschoben würde. Moderatoren, wenn Ihr so freundlich wärt, bitte?

      Edit by Yoshi: Stets zu Diensten. Verschoben und Überschrift ergänzt.


      An zwei Problemen arbeite ich im Moment noch:

      1. Das Bild vom Flugzeug in der Auswahlmaske vom Depot paßt irgendwie noch nicht so recht. Ich habe probiert, mit der Bounding Box sowohl im Blender als auch direkt in der .mdl ein wenig herumzuspielen, um so den Bildausschnitt festzulegen, aber das hat genau gar keinen Einfluß auf dieses Bild gehabt. Wie wird dieser Bildausschnitt festgelegt?

      2. Was genau meinen sie mit "initial pitch on ground"? Nach meinem Sprachverständnis ist "pitch" der Winkel zwischen Flugzeuglängsachse und der Horizontalen. Aber das Flugzeug steht im Blender genau parallel zum Boden und die Auflagefläche der Räder ist genau bei z=0. Wo genau wird von TPF dieser Winkel gemessen, und warum ist es wichtig, daß er kleiner als 0,349066° ist? Die DC-3 und zahlreiche andere Flugzeuge mit Spornrad stehen am Boden alles andere als horizontal, ohne daß sich das Spiel offensichtlich aufregt.

      Wenn hier auch noch jemand eine Antwort weiß, würde ich mich freuen.
      Bilder
      • Screenshot 1.png

        600,36 kB, 841×493, 191 mal angesehen
      • Screenshot 2.png

        10,82 kB, 615×199, 121 mal angesehen

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Yoshi ()

    • Agentbob, danke dir für die Antwort.

      Die Bilder scheinen automatisch beim Export aus Blender zu entstehen (dieser Addon ist echt gut): ich habe das ganze Exportverzeichnis gelöscht und dann neu exportiert, und danach waren sie wieder da. Aber es fehlen auf ihnen halt Nase, Leitwerk und - vielleicht am wichtigsten? - die Räder. Ich habe deswegen den leisen Verdacht, daß meine beiden Probleme zusammenhängen und daß aus irgendeinem Grund der Fehler, der diesen eigenartigen Bildausschnitt generiert, auch für die "Landing Gear Configuration" verantwortlich sein könnte. Aber bisher konnte ich weder eine Ursache für die einzelnen Fehler noch einen echten Zusammenhang festnageln.
    • Vielen Dank euch allen für die Erklärungen.

      Der Grund für das Fahrwerksproblem war offensichtlich, daß die Räder und Achsen nicht gerne in eine Gruppe inkludiert sind. Ich habe sie jetzt da rausgenommen und als separates Mesh eingebaut - und mit einem Mal funktioniert es, das Flugzeug kommt zumindest einmal aus dem Hangar raus. Daß es jetzt noch skaliert gehört und die Nase 90° zur Seite zeigt, werde ich auch noch irgendwie lösen...