Mysteriöse Abstürze "Transportfever.exe funktioniert nicht mehr"

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Gearbest Tablet-PC Promotion promotion
    • Mysteriöse Abstürze "Transportfever.exe funktioniert nicht mehr"

      N'Abend zusammen,
      leider muss ich auch mal die Hilfe der Schwarmintelligenz bzw. einiger Experten in Anspruch nehmen, da meine aktuelle Karte immer mal wieder abstürzt.
      Meistens passiert dies am Monatsanfang, allerdings eher am 2. als am 1. eines Monats.
      Die stdout.txt hänge ich an, nur kann ich mit der Fehlermeldung nicht viel anfangen...
      Die vielen texture load errors sind aber scheinbar nicht das Problem, dass zum Absturz führt.
      Hoffentlich hat von euch jemand eine Idee, es wäre sehr schade um das Savegame...
      Dateien
      • stdout.rar

        (48,44 kB, 39 mal heruntergeladen, zuletzt: )
    • Die interessante Zeile dürfte diese sein.


      Quellcode

      1. c:\build\transport_fever\steam\transport_fever_release\src\game\collision_shape_lib.cpp:646: struct ecs::component::BoundingVolume __cdecl collision_util::BoundingVolumeVisitor::Get(void) const: Assertion `m_visited' failed.
      Da versucht jemand ein Gebäude zu besuchen dessen Kapazität für Besucher schon erreicht ist.
      MfG Maik

      Meine Modelle auf Sketchfab:
      sketchfab.com/maikchaos/models

    • MaikC schrieb:

      Da versucht jemand ein Gebäude zu besuchen dessen Kapazität für Besucher schon erreicht ist.

      Railtim schrieb:

      Nur woran liegt es, dass die Gebäudekapazität erreicht wurde?
      Nein, da versucht niemand ein Gebäude zu besuchen und wird nicht herein gelassen.

      Die Bibliothek, die vom Fehler betroffen ist, ist "collision_shape_lib". Da geht es um Kollisionsprüfung und das Aussehen derselben. Also das was immer so schön rot angezeigt wird und uns regelmäßig in Trübsal verfallen lässt.
      Dabei gibt es eine Datenstruktur "BoundingVolume", der Raum/das Volumen, den/das ein Objekt/eine Kollision umfasst.
      Der, der den Fehler verursacht, ist der "BoundingVolumeVisitor" - ein Ding aus der objektorientierten Programmierung, das zu einem sogenannten "Entwurfsmuster" gehört (en.wikipedia.org/wiki/Visitor_pattern).
      Wenn dieses Ding nun aber kein Objekt zwecks Kollisionsprüfung besucht hat (m_visited == false) bzw. es kein "BoundingVolume" existiert, hat TpF jetzt ein großes Problem...
      if it ain’t broke, don’t fix it... (Meine Röhre: www.youtube.com/c/TomThumbstone)
    • Einfach per Mail zusenden. Bitte aber das dump File nicht vergessen, das hilft meist mehr als die stdout.

      Wenn es nicht zu viel Aufwand ist und eine überschaubare Anzahl an Mods enthält, gerne auch gleich das Savegame dazu.

      Das kann man mehr oder weniger immer unaufgefordert machen, wenn es ein "exotisches" Problem ist, das niemand sofort lösen kann.
      Community-Manager und Projekt-Manager bei Urban Games
    • Hab ich mir gedacht. Danke.

      Aber ist doch mist. ... X/
      Da wird sich so viel zum nächsten Patch von UG gewünscht,- ich wäre schon froh,
      wenn alles stabiler laufen würde, oder wenn man wenigstens wüsste, was Sache ist.

      --------------------------------------------------------------------------------------------------------

      Nachtrag. :cursing:

      Habe das Spiel eben nochmals neu gestartet.
      Einige Züge habe ich auf die Strecke geschickt. Habe diesmal andere Loks und Wagen verwendet. (man weiß ja nie)
      Nach ungefähr 15 Minuten Spielzeit war wieder Ende: TpF funktioniert nicht mehr!
      Auch hier wieder bei der Ausfahrt aus dem Depot. Aber das hann auch Zufall sein.
      Diesmal hatte ich 5 sek. vorher gespeichert, was für ein Wunder.
      Hab das Game dann nochmals gestartet und nach 3 Minuten "TSCHÜSS" TpF funktioniert nicht mehr.
      Diesmal keine Ausfahrt aus dem Depot.
      Die Temp. des Laptop lag bei 42°C, GraKa und Festplatte wurden auf Fehler untersucht. Alles iO.

      Ich habe echt kein Bock mehr. Ich sollte das bischen Freizeit sinnvoller nutzen. :cursing:
      stdout.txt Dies ist die neue stdout.txt nach dem letzten Absturz.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Didi04 ()

    • Da spielt man schon so lange TF und TpF und an das naheliegenste denkt man nicht.
      Hatte die Textur auf HOCH eingestellt. Werde das mal ausprobieren. Möglich das dies die Ursache war.

      ------------------------------------------------------------------------------------------------------------------------

      Nein, leider bringt das nichts.
      Die beiden Savegames, wo nur die Personenzüge fahren, laufen.
      Das Savegame, wo Güterzüge mit dabei sind, stürzt direkt ab. ?(
      Wäre es möglich, das die Import & Export Industrie damit zusammenhängt?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Didi04 ()

    • Du wirst lachen, aber ich habe derzeit auch wieder mit spontanen Abstürzen zu tun, so dass ich seit Beginn des Jahres kaum Freude habe, das Spiel zu genießen. Immer im Hinterkopf, es könnte ja gleich wieder abschmieren... X/ Ein Übeltäter war bei mir besagter "Zug 41", der an einem bestimmten Bahnhof das Spiel zum Absturz brachte, aber scheinbar ist da noch einer unterwegs...
    • Meldungen bekam ich keine, nur die oben von dir geschriebene. Ich hielt alle meine 120 Züge an und lies einen nach dem anderen weiter fahren. "Zug 41" fuhr in einen Bahnhof und schwupps, Spiel tot...Jetzt wollte ich nach und nach die anderen Züge wieder starten, was etwas kompliziert ist, da sich teilweise Staus ergeben...und es schmiert wieder ab :( In dem Savegame steckt viel Arbeit, so dass ich kaum gewillt bin, ein neues zu starten :(
    • Ein kleiner Tip - keine Ahnung ob das was bringt.

      Ich hatte auch mal merkwürdige Abstürze - bei mir lag es an den Linen.

      Schicke mal alle Züge der Linie auf der auch "Zug 41" ins Depot (und verkaufen).
      Lösche die Linie und erstelle diese Linie komplett neu.

      Vielleicht hilft es was?!?
      Ein Bug ist wenn die Hardware nicht versteht was die Software will.
      Zynismus ist meine Rüstung. Sarkasmus mein Schwert und Ironie mein Schild!

      Mein You Tube Kanal - wenn gefällt bitte ein Abo hinterlassen. Danke euch!!

    • JimKnopf824 schrieb:

      Jetzt wollte ich nach und nach die anderen Züge wieder starten, was etwas kompliziert ist, da sich teilweise Staus ergeben...und es schmiert wieder ab In dem Savegame steckt viel Arbeit, so dass ich kaum gewillt bin, ein neues zu starten
      Ja, verstehe. Das ist natürlich ein Problem.
      Bei mir steckt auch viel Arbeit drin und auch ich will nicht immer ein neues Game anfangen.

      Ist es denn wirklich ein gesamter Zug der das Spiel zum Absturz bringt?
      Vieleicht nur einzelne Wagen oder eine Lok?
      Schade das solche Fehler nicht angezeigt werden.

      --------------------------------------------------------------------------------------------------------------

      So, habe eben nochmal das Savegame geladen, welches immer abstürzt. Habe dann, so schnell ich konnte, das Spiel pausiert,
      den Zug der gerade aus dem Depot fuhr, gestoppt und zurück ins Depot geschickt.
      Und auf einmal lief TpF wieder. Doch leider zu früh gefreut. Nach 15 Minuten Spielzeit wieder: "TpF funktioniert nicht mehr" !!! ?( :cursing:

      ----------------------------------------------------------------------------------------------------------------------------------------------------------

      Habe gerade die betroffene Linie komplett abgerissen und neu gebaut. Das gleiche. ABSTURTZ !!!

      Hab echt keinen Bock mehr. :cursing:

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Didi04 ()

    • Ich habe jetzt ein Save das bei ca. 97% tschüss zu mir sagt.

      Hat jemand ne Idee? Mod's wurde nicht verändert.
      Dateien
      • stdout.txt

        (540,68 kB, 130 mal heruntergeladen, zuletzt: )
      Ein Bug ist wenn die Hardware nicht versteht was die Software will.
      Zynismus ist meine Rüstung. Sarkasmus mein Schwert und Ironie mein Schild!

      Mein You Tube Kanal - wenn gefällt bitte ein Abo hinterlassen. Danke euch!!

    • Würde sagen, dass Du irgendein Problem mit Texturen im dds-Format hast:

      Quellcode

      1. c:\build\transport_fever\steam\transport_fever_release\src\lib\renderer\tex_load.cpp:1249: int __cdecl tex_load::LoadDds(const class FileSystem *,enum engine::TexType,const class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > &,unsigned int,bool,bool,bool,bool,int *,int *,int *): Assertion `false' failed.
      In dem Code ist wahrscheinlich etwas in dieser Art

      Quellcode

      1. if blabla == wahr then
      2. tue hier etwas sinnvolles
      3. elseif blubblub == wahr then
      4. tue hier auch etwas sinnvolles
      5. else
      6. -- hier sollten wir nach Adam Riese NIEMALS hinkommen, wenn doch haben wir ein Problem
      7. assert false
      8. end
      Am besten Du schickst das mal nach dem heutigen Patch zu Urban Games...
      if it ain’t broke, don’t fix it... (Meine Röhre: www.youtube.com/c/TomThumbstone)
    • Advertising