Geschwindigkeitsbug

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.

 

Registration and use is of course free for you.

 

We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

  • Es ist kein Mod Problem. Es ist ein Bug in der Fahrzeugsimulation.


    Hatte tatsächlich auch gerade eine Zwangsbremsung von 100 auf 15 km/h.

    Ebenfalls mit dem Fall: Zuggeschwindigkeit (130) > Schienengeschwindigkeit (120).


    Habe dann das letzte Autosave geladen und den gleichen Zug beobachtet. Nix.

    Der Bug ist also nicht reproduzierbar. Daher sollten wir uns keine Hoffnungen machen, dass er je behoben wird...

  • Die Geschwindigkeitsberechnung ist schon eigenartig.

    Den Bug betrifft nur das Verhalten, wenn sich die Geschwindigkeit wirklich abrupt ändert.

    Wenn sie stetig ist, sich aber sehr schnell ändert, also hohe Beschleunigung, liegt das evtl an den Parametern.


    Was haben denn deine Gondeln für ein Gewicht? Vielleicht liegt es daran, dass sie zu leicht sind und hohe Leistung haben.

  • Ich habe in den letzten Tagen auch mehrmals Angstbremsungen erlebt.

    z.B. bei einer Linie mit einem Zug, kurz vor dem Einfahrsignal. Ab dem Signal ist 40 km/h, aber der Zug bremste auf 32 km/h runter, ohne irgendeinen Anlass.


    Oft reduzieren in Bahnhöfe einfahrende Züge zu früh die Geschwindigkeit, um dann wieder leicht zu beschleunigen und dann zu bremsen.

    (mit Realistic Train Brake geht das noch deutlicher und verzögerter ab - also über eine längere Strecke)


    Das kommt mir so vor wie eine Diskrepanz in verschiedenen Teilen des Programmcodes, mal ist es Integer, mal ist es Float oder sowas.


    (In Kerbal Space Program ist auch so ein Fall, da ändern sich ständig die Orbits zwischen 1x Speed und mehr als 8x Speed bei der sogenannte on-rail-simulation. Bei "langsam" wird richtig gerechnet und bei "schneller" wird der Orbit festgelegt, aber mit Rundungsdifferenz).


    Vielleicht gibt es bei Tpf2 ja auch Rundungsdifferenzen bei unterschiedlichen Teilen des Programmcodes?

  • das Problem ist ja nur dann, wenn das Fahrzeug eine höhere zulässige Geschwindigkeit hat wie die Gleise/Strasse.

    Problematisch ist es natürlich, wenn mann sein Gleisvorfeld mit Gleisen schmückt, die unter der Zuggeschwindigkeit liegt. (Habe zwischendurch ein Gleisstück mit 300 eingefügt um die Zwangbremsung zu umgehen)

    Auch wenn du im Bahnhof andere Gleise verwendest und eine länge hast, die über dem Bremswert liegt kann es passieren, das der Zug abstoppt und wieder Beschleunigt.

    Hoffe mal ,dass UG das irgenwann behandelt :/

  • das Problem ist ja nur dann, wenn das Fahrzeug eine höhere zulässige Geschwindigkeit hat wie die Gleise/Strasse.

    Öhm, eindeutig NEIN.


    Denn dann müsste das Abbremsen doch weg sein, wenn man 300 km/h Gleise verlegt und keinen Zug mit dieser Geschwindigkeit drauf fahren lässt.

    Ich habe das bei 160 km/h Gleisen, wenn 140 km/h Loks darauf fahren. Oder halt Loks, die schneller fahren könnten, als 140 km/h. 200 km/h Loks bremsen aber auch ab und beschleunigen wieder und bremsen dann wieder ab und beschleunigen wieder usw usf..


    Ich bekam das erst in den Griff als ich 999 km/h Gleise verbaute. Seither ist mir noch kein Abbremsen aufgefallen.

    Egal, ob dort 140 km/h oder 230 km/h oder 300 km/h Loks darauf fahren.

  • Wichtig wäre vllt mal noch zu wissen wie die Gleise verlegt sind.......

    ZB 300m Gleis = 80km/h danach folgt dann 120km/h oder 200km/h usw

    dann passiert nämlich folgendes die Lok Befindet sich dann auf einen anderen Wert wie der restliche Zug bzw anders rum je nach Richtung . . . .

    HAt das mal einer mit ner ordentlich an bzw Abstieg probiert!?


    aslo zb

    300m 40km/h dann 300m 60km/h dann 300m 80km/h dann 300m 100km/h 300m 40km/h dann 300m 120km/h und da ja Holzschwellen im vanilla nicht schneller gehen nehmen wir mal das als Beispiel.


    Dann wo taucht es am meisten auf im Vorfeld oder auf freier Strecke!?

    Wenn ich hier auf manche Screens schaue dann wird da ja oftmals nen Gleis genommen von rechts nach links über 10 Gleise und über all DKW rein. Dann wird das Gleis in tausende teile zerlegt wenn Ihr euch mal die Lanes anzeigen lasst. Oder baut man schöne Weiche also maximal zb über 2 gleise etc. wie schaut da das Verhalten aus usw.

  • Öhm, eindeutig NEIN.



    Ich habe das bei 160 km/h Gleisen, wenn 140 km/h Loks darauf fahren. Oder halt Loks, die schneller fahren könnten, als 140 km/h. 200 km/h Loks bremsen aber auch ab und beschleunigen wieder und bremsen dann wieder ab und beschleunigen wieder usw usf..

    Ist so .Ein Zug der 200Kmh fährt auf 160Kmh Gleisen bremst ab. Auf Gleisen mit 200Kmh bremst er nicht ab


    Du schreibst selber wenn der Zug schneller ist als die Gleisgeschwindigkeit der Gleise ........


    siehe auch hier:

  • Bei mir war es ein Einfahrgleis mit nur einer Weiche, keine DKW, Strecken-Vmax vor dem EF-Signal 60 km/h und hinter dem Signal 40 km/h.

    Der Zug hatte Vmax 50 km/h.

    Er bremste vor dem Signal auf 32 km/h ab und fuhr dann beschleunigend in den Bahnhof ein, wo er erneut auf ca. 28 km/h runterbremste, dann auf 35 km/h beschleunigte, um wieder zu bremsen für den Halt. Im Bahnhof sind 40 km/h Gleismodule verlegt.