Seit heute eigenartige Abstürze...

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.

 

Registration and use is of course free for you.

 

We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

  • Hallo Leute!


    Seit knapp zwei Wochen spiele ich wieder ein wenig Transport Fever 2. Aktuell bebaue ich die Marias Pass Map aus dem Steam Workshop. Eine sehr großen Map.

    Seit heute habe ich leider eigenartige Abstürze. Sie treten nicht an bestimmten stellen auf. Sondern an beliebigen Stellen, wenn ich die Map überfliege oder mal ein Zug vorbeifährt.

    Anfangs dachte ich, es liegt an einem Asset, da der Fehler häufig in dessen Nähe auftrat. Habe dieses Asset dann aus meiner Map entfernt. Funktionierte auf dem ersten Blick, doch der nächste Absturz ließ nicht lange auf sich warten.


    Ich hatte dann meine Grafikeinstellungen ins Visier genommen. Da ich Annahm, dass die Fehlerquelle mit voller optimistischer Einstellung vor dem Bildschirm saß. Auch ein herunter schrauben der Grafikeinstellungen brachte allerdings kein Erfolg. Dennoch hier die Stats meiner 1060:



    Vielleicht kann mir jemand helfen? :)


    Vielen Dank im Voraus!


    Schranzi

  • Genau das selbe Problem tritt bei mir auch auf. :(

    Mir hatte jemand auf Facebook helfen wollen, leider hatten seine Ideen auch keinen Erfolg. Löschen des Texturen Cash, Realistic Train Brake deaktivieren und meine Linie 1 hat Fehler bei der Beladung.

    Die ersten beiden Sachen habe ich gemacht. Der Fehler taucht trotzdem auf und er findet anscheinend keine Texturen. Warum auch immer. Mit dem Dresden Hbf hatte er nun auch Probleme. Deaktiviert. Und es geht weiter...

  • Bei den Ladefehlern steht auch...Reloaded jansch_roundhouse.lua. Besteht möglicherweise auch ein Zusammenhang mit dem Rinklokschuppen?

    Das ist so eine Endlosschleife. Deaktiviere ich diesen, meckert er beim Dresdner Hbf. Deaktiviere ich diesen ebenfalls, kommt Dresden Neustadt als Fehlerquelle... usw.

    Er meckert ja auch auf einmal, dass er Texturen der Gleismods nicht mehr laden kann. Von jetzt auf gleich hat er damit Probleme.

    Langsam nervt das spiel nur noch. Nach jedem Update funktioniert wieder etwas nicht.

    Mal schauen ob ich irgendwann Lust habe, den Fehler zu finden. Ansonsten fliegt es von der Festplatte.

  • weil Modder ihre Mods anpassen und sich deshalb täglich etwas ändert,

    ein Beispiel ist die MOD von Marc345 Geschwindigkeitsgleise + Module


    Information: With the new update you don‘t need commonapi anymore.

    You can keep the normal mod but you have to disable/remove the commonapi station adapter!


    und so werden bestimmt auch andere Mods sich ändern, wo dann irgendetwas im zusammenhang mit anderen Mods nicht mehr passt

    was natürlich sehr ärgerlich ist, da man erstmal bei der suche verzweifelt

  • Das stimmt allerdings.

    Ich habe wahrscheinlich auch den Übeltäter gefunden. Es lag anscheinend (bin mir aber nicht zu 100% sicher) an der Mod Geschwindigkeitsgleise + Module. Mit dieser habe ich die 140 km/h Gleise gebaut. Als ich diese nun vorsichtig ersetzt habe, lief es. Sie beißt sich wohl mit einer meiner anderen Mods.


    Bis mir das Spiel wieder abstürzte und zwar diesmal wegen einem Soundfehler des Thalys...^^

    Ich glaube, das Spiel möchte mich einfach nur ärgern :D

  • Post by SchranzpartY ().

    This post was deleted by the author themselves: Würde sonst in einem Doppelpost enden ().
  • orgUpdateFn, oppiestation ? NL Train Station ...



    PS: Du solltest den Modularen Adapter Nutzen können, solange CommonAPI2 geladen ist, dann funktionieren auch alt Stationen mit "alt" Gleismodulen + Du kannst dann mit dem Oberleitungstool auch bei den neuen UG basierten Modulen die Oberleitung umschalten, das kann TPF2 sonst ja nicht...

  • In der Beschreibung meines Adapters steht, das man keine weiteren Mods nutzen soll, die die Bahnhofskonstruktion beeinflusst. (Du kannst mit dem Adapter aber auch größere Bahnhöfe bauen, siehe Einstellungen). Die Frage war was mit allen Alt Gleis Modulen geschieht, wie gesagt, die sollten mit Adapter weiterhin funktionieren. Für das Chaos ist UG verantwortlich.

    Beispiele:

    Bahnhofsadapter + neue UG Gleismodule => geht nicht

    Nur alte Gleismodule => gehen nicht


    CommonAPI2 20200630 + Bahnhofsadapter + neue UG Gleismodule => funktioniert

    CommonAPI2 20200630 + Bahnhofsadapter + alte Gleismodule => funktioniert


    Für maximale Nutzerfreundlichkeit sollten Gleispakete entweder die Alt Module ohne Sichtbarkeit mitliefern,

    oder für den Umstieg ein (neues) Paket mit Alt Modulen anbieten für den Übergang.


    Vielleicht mag sich Marcolino26 ja dazu äußern.

  • Bei meinem Test kurz nach Patch:


    Alte Module zeigen nur noch 120 an

    Neue Module mit Adapter nicht platzierbar

    SavegameBahnhöfe mit alten Modulen editieren Crash


    Folge:

    Alte raus, adapter weg, neue rein.


    Was genau hat sich jetzt geändert?

    Man könnte entweder ohne Commonapi benutzen oder mit Commonapi+Adapter? Aber die neuen brauchen ja keinen Adapter und die alten crashen eh.