Immer wieder ein Thema: Bahnhöfe nicht mehr änderbar

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.

 

Registration and use is of course free for you.

 

We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

  • Guten Abend!


    Das Thema ist ja nicht das erste Mal da, mich hat es jetzt schon wieder erwischt. 3. Karte insgesamt, auf jeder immer wieder dieses Problem:



    Ich würde gerne die Gleise austauschen. Geht nicht, weil ich nur noch den Bahnhof komplett abreißen könnte. Dieser Bahnhof ist komplett Vanilla, nur die Gleise nicht. Exakt das Problem habe ich noch auf einer anderen Stelle mit einem modernen Vanilla-Bahnhof mit nur 1 Gleis. Ein anderer Bahnhof, ebenfalls Vanilla und modern, ebenfalls mit den gemoddeten Gleisen, lässt sich problemlos nachträglich ändern.


    Es gab ja schon einige User mit Problemen bei Bahnhöfen, aber so offensichtlich bei reinen Vanilla-Pax-Bahnhöfen ohne Mod und ohne irgendwelche Extras gab es das m.E. noch nicht. Oder ist das doch ein bekannter Bug?


    Hat jemand vielleicht noch einen Tipp für mich, dass ich nicht die nächste Woche damit zubringen werde, den Bahnhof da wieder rein zu fummeln?


    Danke schonmal!

  • Das liegt dann wohl an dem oder den Gleismods, der Bahnhof ist auch nicht Vanilla wenn dort Moddinglgeise verbaut sind. Von dem Thema lese ich aber auch zum ersten mal. Schmeiß doch mal die Moddinggleise raus und teste es dann.


    Den Bahnhof da wieder an exakt die gleiche Stelle zu bauen ist aber auch kein Problem, ist ne Sache von 5 min sind ja nur 4 Gleise. Pause drücken das die Ki nix baut, abreißen und wieder hinbauen da der keine absonderlichen Gleisabschnitte hat passt da ein neuer Bahnhof mit 1 Gleis exakt wieder in die Lücke, dann noch die anderen Gleismodule neu verlegen, passt.

  • Schmeiß doch mal die Moddinggleise raus und teste es dann.

    Äääähhhh :D - exakt das möchte ich ja gerne. Geht aber nicht. Ich kann keine einzige Komponente einzeln entfernen. Auch keinen Bahnsteig, kein Gebäude, kein gar-nix. Und, wie gesagt: ich habe noch zwei weitere Bahnhöfe auf der Map, einfach nur q&d in die Pampa gesetzt. Die haben exakt auch diese Gleise. Einer zickt genauso rum, einer macht überhaupt keine Probleme.



    Den Bahnhof da wieder an exakt die gleiche Stelle zu bauen ist aber auch kein Problem, ist ne Sache von 5 min

    Eher 5 Tage. Es gibt einen Haufen Kollisionen. Mit dem Busbahnhof unten rechts, mit der anschließenden Straße, mit einigen unsichtbaren Straßen, mit den Treppen und der Plattform Richtung Fluss usw. Ich muss ALLES rundherum abreißen und neu bauen und weiß noch nicht, wie weit sich dann sekundäre Probleme noch auswirken.


    Und, wie auch schon gesagt: das passiert mir jetzt auf der dritten von drei Maps. Und die ersten Beiden hatten nur Vanilla-Gleise, das waren WiSim-Spiele.

  • Ich habe nochmal einige Versuche mit den korrupten Bahnhöfen gemacht, komme aber nicht weiter.

    Was bedeutet es nochmal, wenn dieses gelbe Ausrufezeichen erscheint?


    Hier nochmal zwei Bilder eines nun wirklich mehr als simplen Vanilla-Bahnhofs:

    Empfangsgebäude, Bahnsteig, Gleis. Mehr ist nicht. Und trotzdem kann ich den Bahnhof nicht mehr ändern, erweitern oder sonstwie konfigurieren. Nur noch komplett abreißen:



    Noch interessanter sieht es aus, wenn ich ein Gleismodul ansetzen will (die blauen Punkte sind interessanterweise ja da): das Gelände wächst über das Bahnhofsdach und das Aurufezeichen taucht auf:



    Hat da echt niemand eine Idee? Wenn das Ganze nämlich bedeutet, dass ich auf keiner Map sicher sein kann, einen Bahnhof nachträglich nochmal ändern zu können, ohne wieder Tage zu brauchen, um den Zustand wieder herzustellen, könnte es das für mich gewesen sein mit diesem Spiel. Meine Motivation ist jetzt schon nahe Null, den Bahnhof aus dem Eingangspost mitsamt der Umgebung, die ich auch komplett abreißen muss, wieder neu zu bauen. Wäre nicht ganz so schlimm, wenn ich wenigstens wüsste, wie ich das Problem in Zukunft vermeiden kann.

  • Ich glaube, das passiert, wenn sich die Konstruktion des Bahnhofs ändert, hervorgerufen durch Mod Konflikte. Gebaute Konstruktionen auf einer Karte existieren und funktionieren erstmal weiterhin, selbst wenn die Datei/Mod entfernt/überschrieben wurde. Nur beim Upgraden kann es dann zu Problemen kommen, wenn die neue modulare station.con mit dem gebauten irgendwie ungültig wird.


    Das Problem ist einfach, dass das Feature der modularen Stationen intern schlecht umgesetzt ist. Wurde vermutlich unter Zeitdruck programmiert. Entsprechend ist halt das Ergebnis. Vanilla funktioniert zwar alles. Aber Modbarkeit wurde wohl nicht ausreichend berücksichtigt, da sich sofort Kompliktionen ergeben.


    Die modular_station.con hat 1229 Zeilen. Man könnte also sagen, die modularen Bahnhöfe sind ironischerweise nicht wirklich modular programmiert.

  • Das Problem ist einfach, dass das Feature der modularen Stationen intern schlecht umgesetzt ist.

    Das denke ich leider auch. Es wurde wohl "vergessen" zu programmieren, zwischenzeitliche Änderungen an der Konstruktion (dem Modul?) auf ihre Gültigkeit zu überprüfen und zu warnen, bevor vom Spieler etwas gebaut/geändert wird.

    Was im Umkehrschluss heißt: ich werde mich damit abfinden müssen, Bahnhöfe grundsätzlich in dem Zustand lassen zu müssem, in dem ich sie irgendwann mal gebaut habe. Im Schönbau mehr als nervig und Zeit bzw. Nerven kostend, für einen WiSimmer, der es auch ein bisschen schön haben möchte, im Grunde ein Nogo.



    Man könnte also sagen, die modularen Bahnhöfe sind ironischerweise nicht wirklich modular programmiert.

    :D:thumbup: