Signal Distance Hilfe

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.

 

Registration and use is of course free for you.

 

We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

  • Habe mir diese Signal Distance Mod runtergeladen und installiert und Aktiviert, aber die Züge bleiben nach wie vor direkt neben Signal stehen ?


    Was mache ich Falsch ?

    muss ich irgendetwas in den ÖBB Signalen ändern vom Code her ?

    Wenn ja , jedes einzelne *.mdl ???

    Liegt es an der Ladereihenfolge ?

    ÖBB Signale nicht geeignet ?


    BITTE um Hilfe der mir das genauer Erklären kann warum es Nicht geht.


    Ich bedanke mich ....

  • Oebb_Willi

    Changed the title of the thread from “Signal Distance Hife” to “Signal Distance Hilfe”.
  • Habe noch keine Platziert. Starte das Spiel, Lade mir eine Leere Map , meine Test Map, die ist komplett Flach ohne Berge und Leer.


    Wenn ich nun Schienen lege und die Dazugehörigen Gebäude, das ich eine Linie zusammen bekomme...... setze ich nur 1 Signal zum testen.


    Wie gesagt .... jeder Zug bleibt genau bei Signal stehen, als hätte ich diese Mod nicht laufen.

  • So sieht meine mdl vom Block Signal alt aus:


    Muss ich dort explizit etwas ändern ?

  • Ohne jetzt nachzuschauen wie das realisiert ist kann das Verhalten bei den ÖBB-Signalen bestätigen. Ladereihenfolge hat bei mir keine Rolle gespielt. Vanilla, Italien, Russland, Deutschland alles ok, nur bei den ÖBB-Signalen scheint der Mod keine Auswirkung zu haben. Idee habe ich leider auch keine, am Besten mal beim Autor des Mods nachfragen woran das liegen könnte. Der im Singal Distance - Mod genannte Parameter, der das Verhalten deaktivieren soll, konnte ich bei den ÖBB-Signalen nicht finden.

  • Habe den Modder angeschrieben

    und VacuumTube schreibt "Nein, innerhalb von signal


    Code
    1. signal = {
    2. type = "PATH_SIGNAL" ,
    3. dontmove = true,
    4. },
    5. ...

    Kleiner Tipp: Immer erst bei einem testen, bis es geht, und dann auf alle anwenden ;)


    So, habe ich auch gemacht, ohne Erfolg !!!


    Jetzt habe ich 2 Möglichkeiten:


    Ohne Distanz Mod oder andere Signale !

    Hmm... würde zu meinen Schönbau Projekt nicht passen.

    Aber alles kann man eben nicht haben, vielleicht wird es mal behoben.


    Aber Tausend Danke Dunkel für deine Erfahrung das hilft mir jetzt weiter. jetzt weis ich das es bei den ÖBB Signalen NICHT geht, warum auch immer.

  • Schlauer Kerl isii :o)

    Das könnte ich bei der Kleinen "Diarama Map" verwenden, aber da ich eine "XXL MAP Ganz Österreich 1:3" wird das Mühsam bei zig Signalen. jedes Doppelt !?


    Dann arbeite ich soweit es geht mit Auto-Sig mod, eignet sich recht gut für die Langen Strecken, das müsste ich dann auch Doppelt machen, schätze das ich dann den Überblick verliere, K.A


    Aber lieben dank für den Coolen Trick, kann sicher wer gut Brauchen !

  • Du kannst ja mal die mod.lua vom Distance Mod öffnen und den Wert von 8 auf 20 ändern. Vielleicht funktioniert das ja.

    Code
    1. runFn = function (settings)
    2. local distX = 20

    Gruss Andy aus OB
    ---------------------------------------------------------------------------
    Kein Weg ist zu Weit wenn man findet was man sucht

  • Bei mir funktioniert das mit den H/V69 Signalen. Du kannst Bilder direkt hier über Dateianhänge hochladen ohne sie zu verlinken.

    Gruss Andy aus OB
    ---------------------------------------------------------------------------
    Kein Weg ist zu Weit wenn man findet was man sucht

  • Oebb_Willi Ich habe dich falsch verstanden. Ich dachte du willst "dontmove" verwenden, um eine Ausnahme hinzuzufügen. Das ist ja nur ein Sonderfall, wenn man einzelne Signale NICHT verschieben will ("don't move = true" sollte eigentlich für sich sprechen...)


    Wenn ich dich richtig verstehe, willst du die Mod ganz normal nutzen, d.h. ALLE Signale sollen verschoben werden? Dann muss überhaupt nichts geändert werden.

  • Weil es mich auch interessieren würde warum es nicht geht noch eine kleine Anmerkung:

    Dann muss überhaupt nichts geändert werden.

    kann das Verhalten bei den ÖBB-Signalen bestätigen. Ladereihenfolge hat bei mir keine Rolle gespielt. Vanilla, Italien, Russland, Deutschland alles ok, nur bei den ÖBB-Signalen scheint der Mod keine Auswirkung zu haben.

    Ich nehme an Oebb_Willi nutzt auch diesen OEBB Signal-Mod: Österreichische Signale


    Bei dem scheint der "Signal Distance Mod" irgendwie ins Leere zu laufen. Das einzige was mir spontan aufgefallen ist: Bei diesem Signal Mod werden groups verwendet, d.h. ein Teil der transf Informationen steht nicht in der mdl sondern im grp File und die mdl-Struktur ist leicht anders. Ist aber nur eine Beobachtung, da ich keine Ahnung habe ob das für den Mod relevant ist und wie das mit den groups genau funktioniert. Was die Metadaten betrifft müsste der Mod die Signale auf jeden Fall finden.

  • Das einzige was mir spontan aufgefallen ist: Bei diesem Signal Mod werden groups verwendet, d.h. ein Teil der transf Informationen steht nicht in der mdl sondern im grp File und die mdl-Struktur ist leicht anders. Ist aber nur eine Beobachtung, da ich keine Ahnung habe ob das für den Mod relevant ist und wie das mit den groups genau funktioniert.

    Kann es sein, dass diese Mod ein veraltetes mdl Format benutzt?