[Sammelthema] Gefundene/behobene Bugs in Transportfever

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.

 

Registration and use is of course free for you.

 

We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

  • Ich glaube der "Bug" tritt nur im Ausrundungsbogen des Neigungswechsels auf - und da würde die DB auch keine Weiche oder DKW reinbauen ==> kein Bug.

    Stimmt leider nicht. Die falsche Meldung „Steigung zu groß” tritt auch in Fällen auf, wo eben nicht nur der mit der Doppelkreuzweiche zu bebauende Abschnitt völlig eben ist, sondern auch keinerlei Strecken angrenzen, die eine Steigung aufweisen könnten!


    Beiliegend ein Beispiel dafür - ganz aktuelles Bild von heute, also jedenfalls mit der neuesten Build-Version!


    Bitte also den Bug in die Bug-Liste aufnehmen!

  • Die gibt es leider immer wieder mal. Manchmal reicht es, wenn die ganze Umgebung geebnet wird.


    Oft muss ich den Gleiswechsel an einem anderen Ort bauen.

  • @Vred Wenn du nicht gerade die Fläche dort komplett geebnet hast, dann wird das Gleisstück wahrscheinlich eine Neigung und auch einen Neigungswechsel haben.


    Du musst auch folgendes beachten: Wenn du aus einer Steigung kommst und dann manuell die Steigung auf eben stellst, ist das Gleisstück eben dieses mit dem Neigunswechsel. Um einen völlig ebenen Abschnitt zu erhalten, musst du mit dieser Einstellung dann noch weiter bauen.

  • @Werkstatt: Danke fürs Aufnehmen in die Liste;


    Bug Nr. 47 (Das mit der Eingabe von Namen beim Umbenennen) wurde aber mit Build Nr. 13482 behoben!


    Bug Nr. 18: Hier könnte man noch ergänzen, dass bei einem Bahnübergang mit einer Elektrifizierten Straßenbahn die Oberleitungsmasten der Straßenbahn meistens mitten auf den Eisenbahngleisen stehen (nicht nur zwischen den Gleisen).


    Hendi: Ein Bug ist das mit den Weichen auf jeden Fall - möglicherweise tritt aber schon vorher, beim Bauen der geraden Gleisstücke, ein Fehler auf. Ich habe die auf dem Bild zu sehenden Gleisstücke gebaut, indem ich das 1., gerade Gleis in einem Schritt gebaut habe, und die Steigung explizit (also mit Klick auf den waagrechten Pfeil) auf absolut eben gesetzt habe.


    Und zwar ohne dass dieser neu gebaute Gleisabschnitt an andere, bestehende (und möglicherweise geneigte) Gleise, angeschlossen wäre!


    Dann habe ich das 2., parallele, gerade Gleis direkt, eben als Parallel-Gleis, an das 1. daran gebaut.


    Wenn das auf diese Weise gebaute Gleisstück dann trotzdem nicht zur Gänze, auf der vollen Länge, eben ist, dann wäre das eindeutig ein Bug. Wenn ich auf halbwegs geeignetem Gelände (wenn man also nicht grade auf Gebirgshang unterwegs ist) mit der normalen Standard-Bedienung (wohlgemerkt, für den Fall, dass man NICHT an bereits bestehende Gleise anbaut, sondern eben - im Wahrsten Sinn des Wortes - auf der grünen Wiese beginnend) baue, dann erwarte ich schon, dass ich dann auch ein ebenes Gleis bekomme.


    Sofern das jemand genauer feststellen kann, wäre das eventuell noch ein zusätzlicher Bug:
    Nr. 65 (?) Wenn man Gleise mit Steigung 0 baut (auf den waagrechten Pfeil geklickt), werden sie manchmal trotzdem mit Steigung gebaut - auch wenn dabei nicht an bestehende Gleise drangebaut wird (?)


    Mit „?” deswegen, weil ich das nicht mit Sicherheit feststellen kann; Aber wenn, dann könnte man zusätzlich zur Aufnahme als neuer Punkt in die Liste dann auch noch beim Bug Nr. 63 die Anmerkung dazuschreiben: „Möglicherweise teilweise Folgefehler von Bug Nr. 65”


    In den meisten Fällen funktioniert das Bauen der Hosenträgerweiche auf die von mir beschriebene Weise (wie auch schon in der Tipps & Tricks - Abteilung erläutert) eh. Aber hin und wieder kommt es eben zum Bug!


    Abgesehen davon habe ich außerdem immer noch den Eindruck, dass die Prüfung der Steigung beim Bauen von Hosenträgerweichen zu streng eingestellt ist. Ich kann mir auch nicht vorstellen, dass in Wirklichkeit Hosenträgerweichen nur an Stellen gebaut werden, die „tausend-prozentig” eben sind und nicht auch nur die geringste Steigung aufweisen. Dann wären Hosenträgerweichen in der Realität wohl eine absoulte Seltenheit. Mir ist aber bitte schon klar, dass ein Spiel nie zu 100% realistisch sein können wird! Es geht mir nur darum, dass man eben beim Prüfen der Steigung nicht päpstlicher als der Papst sein sollte.

  • Nr. 65 (?) Wenn man Gleise mit Steigung 0 baut (auf den waagrechten Pfeil geklickt), werden sie manchmal trotzdem mit Steigung gebaut - auch wenn dabei nicht an bestehende Gleise drangebaut wird (?)

    Dann haben wir wohl in diesem Punkt aneinander vorbeigeredet. Wenn man ein Gleis einfach so in die Botanik baut, dann hat es als Anfangssteigung eben nicht 0. (Da das so aber auch nicht vorgesehen ist, ist es kein Bug.)


    Das kannst du übrigens leicht selbst austesten:
    Du ziehst erst ein Gleis einfach so in der Landschaft mit der Einstellung "gerade" irgendwo hin.

    Dann ziehst du von dem Ende, zu dem du hingezogen hast, ein Parallelgleis in Richtung des Anfanges des Gleises, aber noch weiter, mit der Einstellung "gerade".

    Wenn sich dann ein Höhenunterschied ergibt, weißt du, dass der Anfanspunkt eines Gleises eben nicht automatisch gerade ist.

  • Wenn man ein Gleis einfach so in die Botanik baut, dann hat es als Anfangssteigung eben nicht 0. (Da das so aber auch nicht vorgesehen ist, ist es kein Bug.)


    Als „Anfangssteigung” (darunter würde ich verstehen: Solange ich noch nicht auf den Pfeil zum Höhe festlegen geklickt habe) darf es ja auch ruhig eine Steigung > 0 haben. Das ist ja, zur Anpassung an die Landschaft, durchaus sinnvoll so!


    Aber sobald ich auf den Pfeil klicke, und explizit auf waagrecht einstelle, dann müsste es (wenn es eben auch nicht an andere Gleise, die eine Steigung aufweisen, angeschlossen ist) doch Steigung 0 bekommen.


    Dass das nicht so ist, ist meiner Meinung nach sehrwohl ein Bug! Denn was soll das für einen Sinn haben? Es muss doch möglich sein, ein neu gebautes, nicht an andere Gleise angeschlossenes und somit völlig unabhängiges Stück Gleis exakt waagrecht zu bauen!


    Also, @Werkstatt ;-), bitte
    Bug Nr. 65:
    Wenn man beim Gleise bauen die Steigung (durch Klick auf den Pfeil) explizit auf 0 setzt, dann ist sie oftmals trotzdem nicht 0, und zwar auch wenn der gebaute Abschnitt nicht an bestehende Gleise mit Steigung angeschlossen ist.

    Und bei Bug Nr. 63 bitte um Ergänzung:
    Möglicherweise Folgefehler von Bug Nr. 65


    (Eventuell kann man ja irgendwann mal einen „Bug oder Feature?” - Thread für diverse Fälle machen, zum abstimmen ;-) )

  • ich spiele tpf in der auflösung 2560x1080 also 2k und auf einem 21:9 monitor . Wenn ich bei einem zug first person mitfahre ..sieht man rechts und links im tunnel die aussenwelt (auch unter die welt).. wäre cool wenn man das beheben könnte das störrt etwas

  • Ist zwar nicht wirklich ein Bug.... Aber soll die Folie vom Opel Blitz so aussehen, wie ein Skelett?
    Wenn du's nich sehen kannst, schau mal in die Mitte der Folie, da sind solche 'Pfeile' nach unten. Darüber noch sowas wie'n (böses) Gesicht. Alles zusammen sieht dann aus wie irgendein Alien-Skelett.
    Bei Bedarf bitte Verschieben und diesen Satz herauslöschen, Danke. Wollte hierfür kein Extra Thema aufmachen.

    LG