Posts by Dschimmi

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.

 

Registration and use is of course free for you.

 

We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

    Hallo zusammen,


    ich hatte eine einfache Linie für Baumaterial in eine Stadt erstellt (die auch Baumaterial benötigt), dort habe ich im Bereich wo das Material gebraucht wird eine Cargo-Entladestelle hingebaut. Ich habe soviele Fahrzeuge auf die Linie gesetzt das sie den Bedarf der Stadt (18) fast decken können (Rate 17). Genauso habe ich auch Steine zur Fabrik geliefert. Alles hat eine Weile funktioniert, irgendwann hat die Fabrik dann aber aufgehört Material zum Versand bereit zu stellen (Produktion läuft munter weiter!). Im Fabrikmenü ist mir ein blinkender gelber Rahmen um "Versand" aufgefallen ... jemand eine Idee wie ich die Fabrik wieder ans laufen bekomme?

    ... hab grad 'ne Karte geladen auf der ich bisher max. 4-7 FPS hatte ... das ding läuft grad mit MINDESTENS 17 FPS! ...mal schauen wie sich's über die Zeit entwickelt ... Ich finde UG hat da 'nen geilen Job gemacht!


    Ach und für die die meinen ich hätte hier 'nen High-End Rechner ... meiner ist inzwischen 7 Jahre alt: I7 980X, GTX Titan, SSD, 12 GB RAM ...

    Hallo Leute,


    folgende Situation:


    Ich habe auf einer Map ein Stück Straße gefunden das TpF zuverlässig zum Absturz bringt. Aufgefallen ist mir das verhalten beim Testen der Mod "unsichtbarer Bahnübergang". Das betreffende Straßenstück ist weit weg von den gebauten Bahnübergängen und hat keinerlei Verbindung zu einem solchen. Das Spiel stürzt ab beim Versuch eine Bushaltestelle an dieses Stück zu bauen und auch beim Versuch die Straße abzureissen.


    Was ich schon versucht habe:
    - Beta Modus abgeschaltet
    - Mod "unsichtbarer Bahnübergang" aus dem Spiel genommen
    - Karte neu generiert - dann lässt sich das Stück abreissen, auch mit gebauten "unsichtbaren BÜ"


    Und nun bin ich ratlos, wenn es nicht mein Mod ist, woran liegt es dann? Hoffe ihr könnt zur Problemfindung und -lösung beitragen. Hier die letzten Zeilen aus der stdout:


    Code
    1. can't connect edge at position (-838.469 / -1182.55)
    2. c:\build\transport_fever\steam\transport_fever_release\src\game\transport\street\construction_util_network.cpp:91: void __cdecl `anonymous-namespace'::ConnectEdge(const class std::unordered_map<class ecs::Entity,class ecs::Entity,struct std::hash<class ecs::Entity>,struct std::equal_to<class ecs::Entity>,class std::allocator<struct std::pair<class ecs::Entity const ,class ecs::Entity> > > &,const class ecs::Engine *,struct transport::NodeId &,const struct CVec2f &,class std::unordered_map<class ecs::Entity,class std::map<int,struct CVec2f,struct std::less<int>,class std::allocator<struct std::pair<int const ,struct CVec2f> > >,struct std::hash<class ecs::Entity>,struct std::equal_to<class ecs::Entity>,class std::allocator<struct std::pair<class ecs::Entity const ,class std::map<int,struct CVec2f,struct std::less<int>,class std::allocator<struct std::pair<int const ,struct CVec2f> > > > > > &,class transport::TransportNetworkConstructor &): Assertion `nodeId.index >= 0' failed.
    3. MinidumpCallback: dumpPath "C:/Program Files (x86)/Steam/userdata/216443903/446800/local/crash_dump/", minidumpId "13116107-2636-482f-b6a4-6ccf01cb822a", succeeded 1
    4. local time is Wed Dec 27 13:31:13 2017

    Versuch mal "von weiter hinten" abzureißen, bei mir funktioniert das dann meistens ... doof nur wenn aufwändige Brücken/Tunnel wegen so was abgerissen werden müssen ...

    Wann der Patch kommt weiß ich nicht, es gibt ja noch nicht einmal eine offizielle Ankündigung. Beim Convinience Patch dauerte es von der offiziellen Ankündigung bis zur Veröffentlichung ca. 2 Monate. Also vor Ostern rechne ich ganz sicher nicht mit dem Patch. Eher noch später.

    Also ich hab kürzlich was getestet, nachdem ich davon gehört habe das die Anzahl der Passagierverbindungen in andere Städte eine Rolle Spielen soll - die Aussage war: "je mehr Verbindungen desto schnelleres Wachstum".


    Ich hab mich also hingesetzt und mal ein wenig herumprobiert - immer mit dem Selben Spielstand gestartet.


    1. Versuch: nichts gebaut -> minimales Stadtwachstum (von 114 auf 208 in 20 Spieljahren)
    2. Nur innerstädtischen Personennahverkehr eingerichtet -> etwas mehr Wachstum als im ersten Versuch. (239 EW nach 20 Jahren)
    3. Eine Personenzuglinie in eine Nachbarstadt eingerichtet (kein PNV aber gute Stadtabdeckung durch den Bahnhof, 2 Züge) -> Ergab nach 20 Jahren 560 EW
    4. Gleich wie 3. nur mit 4 Zügen -> 505 EW (Ich denke, die Abweichung ist "statistisches Rauschen" irgendwo ein paar Wohngebäude im Umbau oder so)
    5. Maschinen und Werkzeuge in die Stadt geliefert -> 287 EW - deutlich mehr als beim ersten Versuch aber nicht wirklich überzeugend
    6. 2 Passagierlinien in zwei Nachbarstädte -> 907 EW - Dieses Ergebnis konnte ich nicht mehr überbieten, auch mit 3 oder 4 Verbindungen nicht.


    Ich gehe durch die obigen Beobachtungen davon aus, dass eine Stadt mindestens 2 Verbindungen braucht und wenn dann noch Waren geliefert werden das Wachstum weiter beschleunigt wird.

    Mir war nicht bewusst, dass die Thüringer da so eigen sind und keine fränkischen Eisenbahnen in ihrem Szenario haben wollen ;-) Nein, Spaß beiseite ... Ich dachte nur wenn das ohnehin auf der Karte mit drauf ist, könnte man die Ludwigsbahn als frühe Aufgabe mit verhackstückeln:


    1. Bau der Strecke
    2. Personentransport
    3. Bierlieferung
    4. Viehtransport
    5. Kohlelieferungen


    Ich denke das könnte eine schöne Einstiegsmission werden, in weiteren Missionen kann man sich dann immer noch nach Thüringen "vorarbeiten".

    Der areaPerTown Parameter greift nur bei neuen Spielen, er regelt hauptsächlich die ANZAHL der Städte de auf der Karte platziert werden, die flächenmäßige Ausdehnung ändert sich dadurch nicht (ich hab's getestet) eine Stadt mit 2000 EW hat immer ungefähr die gleiche Ausdehnung egal ob das Spiel auf 1 km² oder 100km² areaPerTown eingestellt ist.


    Könnte aber sein da sich hier mit dem letzten Patch was geändert hat - da wurd ja auch am Städtewachstum gedreht ...

    Das mit der Versionsanzeige ist ein bisschen Verwirrend, bei manchen Mods wird die an den "regulären" Modnamen mit angehängt ... tut bei dem Problem aber nichts zur Sache ...


    Wenn du die Mod heruntergeladen und _korrekt_ installiert hast, überprüfe doch bitte den Namen der Mod, weil der Spielstand ist schon etwas älter und ich gehe davon aus das die Mod ein Update erfahren hat und jetzt nicht mehr die Version 2.0 sondern Version 2.1 ist. Das Spiel sucht die Mod mit der Bezeichnung 2.0 (die du offensichtlich nicht hast) du solltest dir aber eine Kopie der Mod erstellen können und die Bezeichnung in 2.0 ändern können, dann sollte alles wie erwartet funktionieren.


    Hoffe du bekommst das hin.