Assertion `dist >= .0f' failed. - was ist das?

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.

 

Registration and use is of course free for you.

 

We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

  • Ich hatte den Spielstand 5 Stunden offen und jetzt auf einmal diese Meldung... Es macht echt keinen Spaß mehr. :(




    Assertion Failure: Assertion `dist >= .0f' failed.


    Minidump: D:/Steam/userdata/63394854/1066780/local/crash_dump/babf1780-dfa8-4edc-9610-eb78e2e26d30.dmp


    In file: urban_games/train_fever/src/Game/procedural/util.cpp:18


    In function: float __cdecl LineEvaluator::GetAt(float,struct CVec3f &,struct CVec3f &) const



    __CRASHDB_CRASH__ struct AssertException: urban_games/train_fever/src/Game/procedural/util.cpp:18: float __cdecl LineEvaluator::GetAt(float,struct CVec3f &,struct CVec3f &) const: Assertion `dist >= .0f' failed.

    Exception type: Fatal error


    Details:


    Assertion Failure: Assertion `dist >= .0f' failed.


    Minidump: D:/Steam/userdata/63394854/1066780/local/crash_dump/babf1780-dfa8-4edc-9610-eb78e2e26d30.dmp


    In file: urban_games/train_fever/src/Game/procedural/util.cpp:18


    In function: float __cdecl LineEvaluator::GetAt(float,struct CVec3f &,struct CVec3f &) const

  • Simu4you.de_Daniel

    Changed the title of the thread from “Assertion `dist >= .0f' failed.” to “Assertion `dist >= .0f' failed. - was ist das?”.
  • Servus, die Meldung gibt ja leider keinen Hinweis auf einen Mod. Vermutlich steht in der ganzen stdout.txt nicht mehr hilfreiches drin (immer gut die ganze stdout.txt hochzuladen)? Laut der Meldung scheint ja irgendwas bei der Linienprüfen schiefgegangen zu sein, d.h. mal überlegen was Du da zuletzt verändert hast (neue Linien?, alte gelöscht/geändert?). Falls Du irgendwelche Fahrplan-Mods benutzt mal schauen ob es da Updates gibt oder den mal deaktivieren.

BlueBrixx