transport fever 2 linux native dosent start. gives grapics context creation failed (vulkan)

Willkommen in der Transport Fever Community

Welcome to the fan community of Transport Fever and Train Fever, the economic simulators of Urban Games. The community is free for you to share and inform yourself about the game. We cultivate a friendly and objective interaction with each other and our team will be happy to answer any questions you may have.


Registration and use is of course free for you.


We wish you a lot of fun and hope for active participation.

The Team of the Transport-Fever Community

  • Code


    • installed.txt

      (259.77 kB, downloaded 8 times, last: )
  • I took a look into your installed packages:

    1. systemd-coredump is still missing, the Linux mint link I posted has an URL that apt can read to install the pkg.
    2. You have both flatpak and snapd installed, and since your minidump had those weird paths, it's very certain that you installed Steam via Snap or Flatpak. That's also explains why the vulkaninfo output is fine but your game launch errors. Your game doesn't use the same libraries as it's not really installed on the host but in a "container".
    3. Uninstall libvulkan-dev. You do not need the validation layers unless you develop or run a wlroots based compositor in Vulkan mode. You seem to have installed in explicitly. This removal will also some other pkgs as this is a metapkg.
    4. Are libdrm-radeon1 and libdrm-amdpu1 to different gpu drivers? If so, you have 3 Gpu drivers installed, as the latter name is installed in 2 versions. Use the boring amdgpu driver from your distro, no matter if some internet moron told you that "xy gives me more performance" while it's only 3fps in certain games. If you're inexperienced, you'll run into more trouble than it'll help you anything.
  • I looked into the runtime diagnostics. Uninstall the ppa driver and use the stock, like already said in 4. The weird paths l mentioned

    are from pressure-vessel, which is from the Steam runtime, so that explains that. And because you have Steam mounted at /mnt/steam, it creates those links to work. But shouldn't be a problem.

    Please also remove VkBasalt.

  • the distro drivers are extremely outdated
    performance is one thing but i am still waiting on essential fixes like fan control for the gpu also fsr/raytracing and so on
    even using the link and the install button only gives could not find package "systemd-coredump"

    if i dont actively activate basalt shouldn't it just be silent or idle

    how do i fix number 2?

  • When the drivers are too outdated for you, you're using the wrong Distro. It's not like you're compiling Linux-next and you also didn't manage to fix your installation of newer drivers and no have broken dynamic linking in the userspace part of your gpu drivers. This is just what you get if you buy a GPU from the company that is so miserly with Linux devs that their Linux GPU drivers are only usable from 6 months after the product launch on. Or only buy their products when they're more than a year old. You wouldn't get your card running on Windows 7 or a very old Windows 10, either.

    I'd strongly suggest you switch to Ubuntu 23.10, the most recent Fedora or Arch (archinstall is official now). Cinnamon desktop is in the repos for all of them, no need for Mint. The share objects that try to link wrong should be fixable but even if I'd sit in front of your Computer it'll may take some hours for me if I'm really unlucky.…1-0ubuntu3_amd64.deb.html should exist, maybe you don't have the universe Repo activated in the apt sources? sudo apt edit-sources and remove the comment around universe. If it's not in there, pls search on the internet on how to enable Ubuntu universe or get some guide how to do this on Mint if they deviate from Ubuntu there.

    if i dont actively activate basalt shouldn't it just be silent or idle

    I didn't care to check if it installs some layers so you may be right. Given that Tpf2 in OpenGL mode crashes with a seemingly not graphics related issue, we don't have to care about it yet. But Vulkan certainly loads it all the time or Steam wouldn't have picked it up.

    Nr. 2 is a wrong assumption, I guess I didn't state the explicitly enough ;D You have both Snap and Flatpak installed but installed Steam via apt. Steam does still have its own runtime container with different libraries, though. Forget 2 and this for now.

  • well thats the thing most linux users will tell you amd is much better than nvidia on linux which i also heavily disagree with amd dosent even have a gui software for gpu/grapic settings or driver download everything is just command line and third parties trying their best

    also weird only tf2 has this problem everything else works both opengl and vulkan

    Edited once, last by meki ().

  • also weird only tf2 has this problem everything else works both opengl and vulkan

    Which Linux native games installed via Steam do work for you meanwhile?

    I think I now tried everything to help you install systemd-coredump, which is crucial for finding a solution (other than installing another distro). Please get help on some Linux mint forum, as I do not know their exact differences to Ubuntu.

  • If TPF2 writes it own dmp file because it can't init the Renderer,
    it's technical not crashing from a system standpoint.

    (If no other component in the system generates a fault)

    As TPF2 has no symbols stacktraces are mostly not helpfull. You can use breakpad tools to read tpf2 dmp files... (minidump_stackwalk)

    Technical you could try change the settings to window mode and a small window.

    If SDL2 + TPF2 somehow can't create a fullscreen context, both render systems may not start properly.

  • Window mode, and a small window, something like this:


    screenMode = "WINDOWED",

    windowPos = { 10, 10, },

    windowSize = { 1024, 768, },

    Maybe setting these to true still works:

    rendererDebugGpuCrash = false,

    rendererDebugMode = false,

  • If TPF2 writes it own dmp file because it can't init the Renderer,
    it's technical not crashing from a system standpoint

    I pretty convinced I had cases where Tpf2 writes it's down dump and raises SIGABRT afterwards, which leads to a core dump. Are the codepaths that lead to a the creation of a minidump never calling abort() in the end?

    I used minidump-stackwalk to read the dump, but couldn't understand much from it because missing debug symbols and I've only worked with core files so far. Is there a wiki entry which sections are may contain relevant information regarding the crash cause? I couldn't find one.

  • with game scope it gets stuck even trying to force close it with steam dos not do anything

    "Maybe also start Steam with logging for the Steam runtime enabled" how do i do that?

  • Gamescope is the Wayland compositor of SteamOS. You can use it as an intermediate layer if some games have problems related to window management. It installs a signal handler if not set otherwise so you'd have to kill the process. So it's definitely not window management related.

    Click the Link for a guide on how to enable Steam runtime logging and where to obtain the log.

  • interesting the log file itself dos not give anything or isnt created. but the terminal window used to launch steam with the argument is a decent read
    and gives pretty much the same output with vulkan/opengl and/nor ...radeon_icd.x86_64.json %command%

    Edited once, last by meki ().